use strict;
my $str = 'PERU
Liga 2
]
Final
Santa Rosa
0-3
Molinos El Pirata
73
Chavelines
1-0
Deportivo Coopsol
20:30
Comerciantes Unidos
-
Juan Aurich
22:45
Santos FC
-
Huaral
90+1
Pogon Szczecin
2-0
Stal Mielec
live
20:30
Plock
-
Gornik Z.
21:15
Farense
-
Maritimo
';
my $regex = qr/^((?:Final)|(?:\d{2}:\d{2})|(?:\d{1,3}(?!\d)(?!-)))/mp;
my $subst = 'newLine$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";