$re = '/^((?:Final)|(?:\d{2}:\d{2})|(?:\d{1,3}(?!\d)(?!-)))/m';
$str = 'PERU
Liga 2
]
Final
Santa Rosa
0-3
Molinos El Pirata
73
Chavelines
1-0
Deportivo Coopsol
20:30
Comerciantes Unidos
-
Juan Aurich
22:45
Santos FC
-
Huaral
90+1
Pogon Szczecin
2-0
Stal Mielec
live
20:30
Plock
-
Gornik Z.
21:15
Farense
-
Maritimo
';
$subst = "newLine$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;