using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"newLine";
string substitution = @"\n";
string input = @"newLineFinal Santa Rosa 0-3 Molinos El Pirata newLine73 Chavelines 1-0 Deportivo Coopsol newLine20:30 Comerciantes Unidos - Juan Aurich newLine22:45 Santos FC - Huaral newLine90+1 Pogon Szczecin 2-0 Stal Mielec live newLine20:30 Plock - Gornik Z. newLine21:15 Farense - Maritimo ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}