import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "newLine";
final String string = "newLineFinal Santa Rosa 0-3 Molinos El Pirata newLine73 Chavelines 1-0 Deportivo Coopsol newLine20:30 Comerciantes Unidos - Juan Aurich newLine22:45 Santos FC - Huaral newLine90+1 Pogon Szczecin 2-0 Stal Mielec live newLine20:30 Plock - Gornik Z. newLine21:15 Farense - Maritimo ";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}