import Foundation
let pattern = #"newLine"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"newLineFinal Santa Rosa 0-3 Molinos El Pirata newLine73 Chavelines 1-0 Deportivo Coopsol newLine20:30 Comerciantes Unidos - Juan Aurich newLine22:45 Santos FC - Huaral newLine90+1 Pogon Szczecin 2-0 Stal Mielec live newLine20:30 Plock - Gornik Z. newLine21:15 Farense - Maritimo "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)