package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)newLine`)
var str = `newLineFinal Santa Rosa 0-3 Molinos El Pirata newLine73 Chavelines 1-0 Deportivo Coopsol newLine20:30 Comerciantes Unidos - Juan Aurich newLine22:45 Santos FC - Huaral newLine90+1 Pogon Szczecin 2-0 Stal Mielec live newLine20:30 Plock - Gornik Z. newLine21:15 Farense - Maritimo `
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}