using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\""\w+\""|[+-]?\d{1,3}\.?\d{1})+";
string input = @"""dadada"";-15.7;15;""TRUE""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}