package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\"\w+\"|[+-]?\d{1,3}\.?\d{1})+`)
var str = `"dadada";-15.7;15;"TRUE"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}