// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:\"\w+\"|[+-]?\d{1,3}\.?\d{1})+"#).unwrap();
let string = "\"dadada\";-15.7;15;\"TRUE\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}