$re = '/(?:\"\w+\"|[+-]?\d{1,3}\.?\d{1})+/';
$str = '"dadada";-15.7;15;"TRUE"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);