#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\.\d{4}\.ext$).+$"
Local $sString = "this is a 9876 file name .1234.ext" & @CRLF & _
"thisisa9876filename .4321.ext" & @CRLF & _
"thisisa9876filename.123.ext" & @CRLF & _
"thisisa9876filename.12345.ext" & @CRLF & _
"this is a 9876 file name.txe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")