const regex = /^(?!.*\.\d{4}\.ext$).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\.\\d{4}\\.ext$).+$', 'gm')
const str = `this is a 9876 file name .1234.ext
thisisa9876filename .4321.ext
thisisa9876filename.123.ext
thisisa9876filename.12345.ext
this is a 9876 file name.txe`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}