using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\.\d{4}\.ext$).+$";
string input = @"this is a 9876 file name .1234.ext
thisisa9876filename .4321.ext
thisisa9876filename.123.ext
thisisa9876filename.12345.ext
this is a 9876 file name.txe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}