$re = '/^(?!.*\.\d{4}\.ext$).+$/m';
$str = 'this is a 9876 file name .1234.ext
thisisa9876filename .4321.ext
thisisa9876filename.123.ext
thisisa9876filename.12345.ext
this is a 9876 file name.txe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);