#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((.*\n){1,2})(.*)((.*\n){0,2}.*\n?\z)"
Local $sString = "This could" & @CRLF & _
"be "words"" & @CRLF & _
"or any text" & @CRLF & _
"or pattern" & @CRLF & _
"or any amount of lines" & @CRLF & _
"need 3 groups:" & @CRLF & _
"1 -> lines 1 to 2" & @CRLF & _
"2 -> lines leftover" & @CRLF & _
"3 -> last 3 lines" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")