const regex = /^((.*\n){1,2})(.*)((.*\n){0,2}.*\n?\z)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((.*\\n){1,2})(.*)((.*\\n){0,2}.*\\n?\\z)', 'mg')
const str = `This could
be "words"
or any text
or pattern
or any amount of lines
need 3 groups:
1 -> lines 1 to 2
2 -> lines leftover
3 -> last 3 lines
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}