import re
regex = re.compile(r"^((.*\n){1,2})(.*)((.*\n){0,2}.*\n?\z)", flags=re.MULTILINE)
test_str = ("This could\n"
"be \"words\"\n"
"or any text\n"
"or pattern\n"
"or any amount of lines\n"
"need 3 groups:\n"
"1 -> lines 1 to 2\n"
"2 -> lines leftover\n"
"3 -> last 3 lines\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")