import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((.*\\n){1,2})(.*)((.*\\n){0,2}.*\\n?\\z)";
final String string = "This could\n"
+ "be \"words\"\n"
+ "or any text\n"
+ "or pattern\n"
+ "or any amount of lines\n"
+ "need 3 groups:\n"
+ "1 -> lines 1 to 2\n"
+ "2 -> lines leftover\n"
+ "3 -> last 3 lines\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}