using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!http(s)?:\/\/|~).*";
string input = @"mailto:episerver@episerver.com
http://www.episerver.comm
~/link/00000000000000000000000000000000.aspx""
!imakeyourjobcrash
ftp://ftp.warez.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}