$re = '/^(?!http(s)?:\/\/|~).*/m';
$str = 'mailto:episerver@episerver.com
http://www.episerver.comm
~/link/00000000000000000000000000000000.aspx"
!imakeyourjobcrash
ftp://ftp.warez.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);