re = /^(?!http(s)?:\/\/|~).*/m
str = 'mailto:episerver@episerver.com
http://www.episerver.comm
~/link/00000000000000000000000000000000.aspx"
!imakeyourjobcrash
ftp://ftp.warez.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end