import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!http(s)?:\\/\\/|~).*";
final String string = "mailto:episerver@episerver.com\n"
+ "http://www.episerver.comm\n"
+ "~/link/00000000000000000000000000000000.aspx\"\n"
+ "!imakeyourjobcrash\n"
+ "ftp://ftp.warez.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}