import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\d{1,2}[a-z]\\s*[a-z]{2}\\s*\\d{2,5}\\s*\\d{2,5}\\/\\/\\s*\\d+(?:\\s*(?:years|days|weeks))?";
final String string = "blah blah blah blah blah MGRS:12ABC12345678// 13 weeks blah blah blah blah MGRS: 98ZYX87654321// 9 days blah blah blah)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}