$re = '/(?i)\d{1,2}[a-z]\s*[a-z]{2}\s*\d{2,5}\s*\d{2,5}\/\/\s*\d+(?:\s*(?:years|days|weeks))?/';
$str = 'blah blah blah blah blah MGRS:12ABC12345678// 13 weeks blah blah blah blah MGRS: 98ZYX87654321// 9 days blah blah blah)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);