import re
regex = re.compile(r"(?i)\d{1,2}[a-z]\s*[a-z]{2}\s*\d{2,5}\s*\d{2,5}\/\/\s*\d+(?:\s*(?:years|days|weeks))?")
test_str = "blah blah blah blah blah MGRS:12ABC12345678// 13 weeks blah blah blah blah MGRS: 98ZYX87654321// 9 days blah blah blah)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")