import Foundation
let pattern = #"(?i)\d{1,2}[a-z]\s*[a-z]{2}\s*\d{2,5}\s*\d{2,5}\/\/\s*\d+(?:\s*(?:years|days|weeks))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"blah blah blah blah blah MGRS:12ABC12345678// 13 weeks blah blah blah blah MGRS: 98ZYX87654321// 9 days blah blah blah)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)