using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Title"":""(?<Title>.*?)"".""Department"":""(?<Department>.*?)"".""Name"":""(?<Name>.*?)"".""Phone"":""(?<Phone>.*?)""";
string input = @"{""searchRecords"":[{""attributes"":{""type"":""Contact"",""url"":""/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS""},""Title"":""Implementation Manager"",""Department"":""Builds"",""Name"":""Erik Leiren"",""Phone"":""2062517122""},{""attributes"":{""type"":""Contact"",""url"":""/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ""},""Title"":""Medical Assistant"",""Department"":""Medical"",""Name"":""Danielle Johnson"",""Phone"":""(206) 251-7122""},{""attributes"":{""type"":""Contact"",""url"":""/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA""},""Title"":""Platform Engineer"",""Department"":""PE"",""Name"":""Erik J. Leiren"",""Phone"":""2062517122""}]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}