// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"Title":"(?<Title>.*?)"."Department":"(?<Department>.*?)"."Name":"(?<Name>.*?)"."Phone":"(?<Phone>.*?)""#).unwrap();
let string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS\"},\"Title\":\"Implementation Manager\",\"Department\":\"Builds\",\"Name\":\"Erik Leiren\",\"Phone\":\"2062517122\"},{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ\"},\"Title\":\"Medical Assistant\",\"Department\":\"Medical\",\"Name\":\"Danielle Johnson\",\"Phone\":\"(206) 251-7122\"},{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA\"},\"Title\":\"Platform Engineer\",\"Department\":\"PE\",\"Name\":\"Erik J. Leiren\",\"Phone\":\"2062517122\"}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}