import re
regex = re.compile(r"\"Title\":\"(?<Title>.*?)\".\"Department\":\"(?<Department>.*?)\".\"Name\":\"(?<Name>.*?)\".\"Phone\":\"(?<Phone>.*?)\"", flags=re.MULTILINE)
test_str = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS\"},\"Title\":\"Implementation Manager\",\"Department\":\"Builds\",\"Name\":\"Erik Leiren\",\"Phone\":\"2062517122\"},{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ\"},\"Title\":\"Medical Assistant\",\"Department\":\"Medical\",\"Name\":\"Danielle Johnson\",\"Phone\":\"(206) 251-7122\"},{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA\"},\"Title\":\"Platform Engineer\",\"Department\":\"PE\",\"Name\":\"Erik J. Leiren\",\"Phone\":\"2062517122\"}]}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")