use strict;
my $str = '{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS"},"Title":"Implementation Manager","Department":"Builds","Name":"Erik Leiren","Phone":"2062517122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ"},"Title":"Medical Assistant","Department":"Medical","Name":"Danielle Johnson","Phone":"(206) 251-7122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA"},"Title":"Platform Engineer","Department":"PE","Name":"Erik J. Leiren","Phone":"2062517122"}]}';
my $regex = qr/"Title":"(?<Title>.*?)"."Department":"(?<Department>.*?)"."Name":"(?<Name>.*?)"."Phone":"(?<Phone>.*?)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}