using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]{13}\\x11([\s가-힣a-zA-Z0-9]{2,})\(";
string input = @"
8604286280013\x11TRAN THI KIM THUY(44000(\x030.1(53575\x015\t507030360)(주)에이플러스에셋어드바이저\x0201\x010\x0200\x0710MS350\x0bGA3-5지점\x0820210331\x12314004468202103317\x0231\x010\x0820210331\n
[0-9]{13}([\s가-힣a-zA-Z]{2,})\(
[0-9]{13}\\x11[\s가-힣a-zA-Z]{3,}\(
[0-9]{13}\\([\s가-힣a-zA-Z0-9]{3,})\(";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}