// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]{13}\\x11([\s가-힣a-zA-Z0-9]{2,})\(").unwrap();
let string = "
8604286280013\\x11TRAN THI KIM THUY(44000(\\x030.1(53575\\x015\\t507030360)(주)에이플러스에셋어드바이저\\x0201\\x010\\x0200\\x0710MS350\\x0bGA3-5지점\\x0820210331\\x12314004468202103317\\x0231\\x010\\x0820210331\\n
[0-9]{13}([\\s가-힣a-zA-Z]{2,})\\(
[0-9]{13}\\\\x11[\\s가-힣a-zA-Z]{3,}\\(
[0-9]{13}\\\\([\\s가-힣a-zA-Z0-9]{3,})\\(";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}