import re
regex = re.compile(r"[0-9]{13}\\x11([\s가-힣a-zA-Z0-9]{2,})\(", flags=re.MULTILINE)
test_str = ("\n\n"
"8604286280013\\x11TRAN THI KIM THUY(44000(\\x030.1(53575\\x015\\t507030360)(주)에이플러스에셋어드바이저\\x0201\\x010\\x0200\\x0710MS350\\x0bGA3-5지점\\x0820210331\\x12314004468202103317\\x0231\\x010\\x0820210331\\n\n\n\n\n"
"[0-9]{13}([\\s가-힣a-zA-Z]{2,})\\(\n"
"[0-9]{13}\\\\x11[\\s가-힣a-zA-Z]{3,}\\(\n"
"[0-9]{13}\\\\([\\s가-힣a-zA-Z0-9]{3,})\\(")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")