import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<(?<tag>\\w+)(\\s[^>]*)*>(?>[^<])*<\\/\\k<tag>\\s*>)";
final String string = "<div> <p> <b>BOLD</b> <ios>ITALIC</i> <b>BOLD</b> </p> </div>\n"
+ "<span class=\"title\">Account</span>\n"
+ "<a class=\"component\"><span class=\"bars\"></span><span class=\"title\">Report</span></a>\n"
+ "<p>IS A TAG</p>\n"
+ "<p>TAG NOT MATCHED</b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}