import re
regex = re.compile(r"(<(?<tag>\w+)(\s[^>]*)*>(?>[^<])*<\/\k<tag>\s*>)", flags=re.MULTILINE)
test_str = ("<div> <p> <b>BOLD</b> <ios>ITALIC</i> <b>BOLD</b> </p> </div>\n"
"<span class=\"title\">Account</span>\n"
"<a class=\"component\"><span class=\"bars\"></span><span class=\"title\">Report</span></a>\n"
"<p>IS A TAG</p>\n"
"<p>TAG NOT MATCHED</b>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")