import Foundation
let pattern = #"(<(?<tag>\w+)(\s[^>]*)*>(?>[^<])*<\/\k<tag>\s*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div> <p> <b>BOLD</b> <ios>ITALIC</i> <b>BOLD</b> </p> </div>
<span class="title">Account</span>
<a class="component"><span class="bars"></span><span class="title">Report</span></a>
<p>IS A TAG</p>
<p>TAG NOT MATCHED</b>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)