re = /(<(?<tag>\w+)(\s[^>]*)*>(?>[^<])*<\/\k<tag>\s*>)/m
str = '<div> <p> <b>BOLD</b> <ios>ITALIC</i> <b>BOLD</b> </p> </div>
<span class="title">Account</span>
<a class="component"><span class="bars"></span><span class="title">Report</span></a>
<p>IS A TAG</p>
<p>TAG NOT MATCHED</b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end