package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{2}-\d{3}-\d{3}-\d{3}|\d{11})$`)
var str = `46123456789
46-123-456-789
46-123-456-789
+46-123-456-789
+46123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}