import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{2}-\\d{3}-\\d{3}-\\d{3}|\\d{11})$";
final String string = "46123456789\n"
+ "46-123-456-789\n"
+ "46-123-456-789\n"
+ "+46-123-456-789\n"
+ "+46123456789";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}