package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\()?(\d{3})(?(1)\)|)([\.\s-])?(\d{3})(?(3)[\.\s-]|[\.\s-]?)(\d{4})`)
var str = `123 456 7890 (123) 456-7890 (123)456-7890 123 456 7890 123.456.7890 (blank/null) 1234567890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}