const regex = new RegExp('(\\()?(\\d{3})(?(1)\\)|)([\\.\\s-])?(\\d{3})(?(3)[\\.\\s-]|[\\.\\s-]?)(\\d{4})', 'gm')
const str = `123 456 7890 (123) 456-7890 (123)456-7890 123 456 7890 123.456.7890 (blank/null) 1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}