#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-3]?[0-9]{1}[0]{2}|4[0-3]{1}[0]{2})$"
Local $sString = "100" & @CRLF & _
"200" & @CRLF & _
"300" & @CRLF & _
"500" & @CRLF & _
"4000" & @CRLF & _
"4400"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")