re = /^([1-3]?[0-9]{1}[0]{2}|4[0-3]{1}[0]{2})$/m
str = '100
200
300
500
4000
4400'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end