$re = '/^([1-3]?[0-9]{1}[0]{2}|4[0-3]{1}[0]{2})$/m';
$str = '100
200
300
500
4000
4400';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);