package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-3]?[0-9]{1}[0]{2}|4[0-3]{1}[0]{2})$`)
var str = `100
200
300
500
4000
4400`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}