package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{1,2}\/[a-zA-Z]-[0-9]\/[A-Z]+\/([0-9.]+\/)?[0-9]+$`)
var str = `11/A-9/XI/2015
12/A-9/XII/2.99/2015
12/A-9/XII/2.99/a2015
a12/A-9/XII/2.99/2015
12/A-9/XII/2.99/2015a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}