const regex = /^[0-9]{1,2}\/[a-zA-Z]-[0-9]\/[A-Z]+\/([0-9.]+\/)?[0-9]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{1,2}\\\/[a-zA-Z]-[0-9]\\\/[A-Z]+\\\/([0-9.]+\\\/)?[0-9]+$', 'gm')
const str = `11/A-9/XI/2015
12/A-9/XII/2.99/2015
12/A-9/XII/2.99/a2015
a12/A-9/XII/2.99/2015
12/A-9/XII/2.99/2015a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}