// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]{1,2}\/[a-zA-Z]-[0-9]\/[A-Z]+\/([0-9.]+\/)?[0-9]+$").unwrap();
let string = "11/A-9/XI/2015
12/A-9/XII/2.99/2015
12/A-9/XII/2.99/a2015
a12/A-9/XII/2.99/2015
12/A-9/XII/2.99/2015a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}