package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)旅行名稱:(?P<TourName>.*?),價錢:(?P<Price>[\d,]+),日期:\d{4}/\d{2}/\d{2}</p>`)
var str = `<p>旅行名稱:去韓國玩,價錢:5,000,日期:2018/03/20</p><p>旅行名稱:去日本玩,價錢:8,000,日期:2018/07/15</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}