import Foundation
let pattern = #"旅行名稱:(?P<TourName>.*?),價錢:(?P<Price>[\d,]+),日期:\d{4}/\d{2}/\d{2}</p>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<p>旅行名稱:去韓國玩,價錢:5,000,日期:2018/03/20</p><p>旅行名稱:去日本玩,價錢:8,000,日期:2018/07/15</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)